Posts Tagged ‘bugs’

We have the technology ..

Saturday, July 11th, 2009

We have the technology, we can fix it. The nice thing about showing people things that are broken and then sitting down to figure out what’s wrong is that the things get fixed. Holger helped out with understanding some of the rendering issues on the Sun Ray server, we tracked down some more suitable default themes (but there’s so many cool themes out there it’s hard to find a boring flat one), pushed graphicssystem RASTER into startkde, and ended up with a KDE4 that looks like this. Thin client heaven? I think not, but it’s a little better than when it started. Just a wee bit, though, even something totally flat like Heron (wish list: semantic tagging of plasma themes so I can search for “flat and boring”) totally borks the plasma panel.

Aaron was, probably rightly so, kind of annoyed with my cheap shot about ugliness on feature-limited X servers.

Still, it’s important to flag the problems, show them to people. The cheapness was more related to me complaining to the wrong people, but now at GCDS I could show them to the Sun Ray folks — and I’m very happy to have met Bob, Brian, Ken (?) and others from Sun — and collect information. It looks mostly like Qt has two problems: the fallback for non-porter-duff compositing is not very nice, and BGR colormaps are not supported. That’s the guesses from the Sun folk and they sound plausible enough — I’ll be trying them out when I get back home and can spend an evening re-compiling Qt all the time (instead of like here at GCDS where the evenings are for discussion and food).

.. and then we can fix it.


Friday, July 10th, 2009

[[ Some notes from behaving like a BugSquad member. Picture of the real deal on the dot. ]]

There was a BoF session on a timezone bug, where Pau Garcia y Quiles brought together folks running all kinds of Linux distros and other Free Software operating systems to examine system timezone setting. That has yielded lots of new information, but not yet a resolution. Changing system timezone on Solaris seems to require a reboot – that doesn’t seem right. I’ll have to play with the GNOME code to see what it does.

Re-tagged a bunch of old bugs that were not FreeBSD-specific to the “All” operating system after checking the bug still exists in current 4.3-rc1 on Solaris.

On monday evening, I wrote a BugSquad song. I guess those are the only 12 lines of original content I’ve written so far?